正點財經首頁     加入收藏
指標首頁 通達信指標 同花順指標 大智慧指標 飛狐指標 指標教程 指標實戰 指標百科 股市學院
指標源碼搜索: 熱詞:買賣  黑馬  K線  牛股  量能  波段  頂底  抄底  成本  逃頂  MACD  漲停  換手率
你的位置: > 正點財經 > 炒股指標公式 > 同花順指標公式 > 同花順MACD定量結構指標公式

同花順MACD定量結構指標公式

同花順指標公式源碼概況:
  • 指標類別: 同花順指標公式
  • 授權方式: 免費版
  • 指標評級: ★★★★★
  • 指標分類: 趨勢
  • 畫線方法: 副圖
  • 日期:2018-07-27 來源:互聯網
同花順指標公式源碼介紹:

      同花順MACD定量結構指標公式(分類:指標源碼)同花順MACD定量結構指標是MACD稱為指數平滑移動平均線,是從雙指數移動平均線發展而來的,由快的指數移動平均線(EMA12)減去慢的指數移動平均線(EMA26)得到快線DIF,再用2×(快線DIF-DIF的9日加權移動均線DEA)得到MACD柱。

      同花順MACD定量結構指標使用說明:①股價新高或者新低,MACD指標中的DIF卻未隨之新高或新低,謂之“鈍化”。 ②當鈍化出現后,dif的值反向轉折,謂之“結構形成”,此時應買入或賣出。dif的值在和前高或前低比較時,按照前極值的數量級,只比較前兩位數字。

同花順MACD定量結構指標源碼:

DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),LINETHICK2;
DEA:EMA(DIF,9),LINETHICK2,COLORRED;
MACD:(DIF-DEA)*2,COLORSTICK,LINETHICK3;

上翹:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORWHITE,LINETHICK2;
下拐:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORBLUE,LINETHICK2;

死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背離:=(CL1MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背離:=(CL1MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背離 OR 隔峰底背離);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背離,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背離,1));
底背離消失:=(REF(直接底背離,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背離,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,8,0),COLORRED;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'鈍化'),COLORYELLOW;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'結構形成'),COLORMAGENTA;
DRAWTEXT(FILTER(底背離消失,10),(DIF+MACD),'消失'),COLORGREEN;
STICKLINE(BG,0,(DIF+DEA),2,0), COLORRED;
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接頂背離:=(CH1>CH2 ) AND (MDIFT20 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰頂背離:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT30 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接頂背離 OR 隔峰頂背離);
TG:=((MDIFT2 頂背離消失:=(REF(直接頂背離,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰頂背離,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA),2,0), COLORGREEN;
STICKLINE(T OR TG,DIF,DEA,8,0),COLORGREEN;
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'結構形成'),COLORMAGENTA;
DRAWTEXT(FILTER(頂背離消失,20),(DIF+MACD),'消失'),COLORGREEN;

 

同花順MACD定量結構指標實戰案例:
 
通達信MACD定量結構指標公式
同花順MACD定量結構指標:
  科大訊飛(002230)是人工智能概念龍頭,主營業務:主要由語音支撐軟件、行業應用產品/系統、信息工程和運維服務。在2017年1月23日同花順MACD定量結構指標出現結構形成信號,后面七個交易日上漲10%。同花順MACD定量結構指標更新時間:2018-3-5 16:14
同花順指標相關閱讀
  • 風云榜
  • 總點擊榜
  • 最新指標
月點擊榜指標公式
更多指標百科
關于我們 | 廣告服務 | 聯系方式 | 意見反饋 | 合作伙伴 | 法律聲明 | 網站地圖
正點財經網所載文章、數據等內容純屬作者個人觀點,僅供投資者參考,并不構成投資建議。投資者據此操作,風險自擔。
山西快乐10分玩法 中国铁建股票 新快乐3最新开奖 福建体彩22选5开奖走势 中首投资 35选7开奖结果 金慧配资 全民红中麻将作弊器下载 盛谷策略配资 上海百搭麻将玩法 琼崖海南麻将软件 日本麻将手游 星悦云南麻将手机版下载 配资存在哪些风险 推倒胡算账规则 台湾麻将16张游戏 四断勾卡血战麻将破解版